Top Menu

Enable Synology DTS transcoding with ffmpeg

Synology does NOT support DTS on its products due to licensing problems if I’m not mistaken. But there is a workaround for this. What we need to do is install a 3rd party ffmpeg package and that’s all 🙂

Install ffmpeg package to your Synology NAS

1. Go to the Package Center and click on Settings.

Synology_DTS_codec_12. Click on ‘Package Sources’.

Synology_DTS_codec_23. Click ‘Add’ and enter the following details.

Synology_DTS_codec_3Name: SynoCommunity

Location: http://packages.synocommunity.com/

4. Click ‘OK’ to save your changes. Then click on ‘General’ tab and select ‘Any publisher’ in the Trust Level section.

Synology_DTS_codec_4

5. From the Package Center, select Community tab on the left hand side and look for ffmpeg (If you can’t see the package you might need to hit the ‘Refresh’ button). Install ffmpeg by clicking on ‘Install’ button.

Synology_DTS_codec_5

6. Click on ffmpeg and check if it’s running. If not, click on ‘Action’ and select ‘Run’.

Synology_DTS_codec_6

That’s it! It should all be working now! Your Synology NAS now support media with DTS codec!

This is tested on DS216play running DSM 6.0.2-8451 Update 7. Please let me know on the comments section below if it work for other Synology NAS models.

Check what Synology NAS can and can’t transcode [link]

Updated 14-06-2017

I am currently running on DSM 6.1.1-15101 Update 4 and everything still running smoothly.

Updated 03-10-2017

Confirmed working on DS416Play.

I am currently running on DSM 6.1.3-15152 Update 5

 

, , , , , , , , ,

  • Victor303

    Same problem with my DS218. Found any solutions. Maybe do to x64 version ?

  • tokjdm

    DS214 Play, latest DSM software version.
    Still no sound but only when playing through Chromecast
    (same situation as before)

  • Oscar

    Thanks for sharing.

  • struna

    Not working on my ds718+ with DSM 6.1.3-15152 Update 8

    Followed all steps and triple checked it.

  • Oscar

    Do you have other applications installed on your NAS? Maybe disable or uninstall other apps?

  • Vesper Hunt

    I have tried it on all browsers even apple tv and phone using the DS Video App. I have tried multiple EAC3 files and none of them work.

    I have also uninstalled it multiple times. It worked fine for awhile then all of sudden it stopped playing those files…Is there any else you would recommend I try?

  • Oscar

    Hi Vesper,

    Majority of my media files are encoded in AC3. But I managed to get a file encoded in EAC3 and it worked for me. I was able to play the file on VideoStation using Chrome browser and I was able to chromecast it to my TV via DS Video app.

    Is it just one file having problem or all your EAC3 files? Maybe try uninstalling ffmpeg and install it again.

  • Vesper Hunt

    Ok, any suggestions on why it wont work? I am trying to play video files with EAC3 audio.

  • Oscar

    Hi, I have updated to DSM 6.1.3-15152 Update 7 and is it still working fine 🙂

  • Vesper Hunt

    Can you confirm it is working for: DS216play – DSM 6.1.3-15152 Update 7 ?

    Thanks

  • Oscar

    Probably a silly question, but did you hit the ‘Refresh’ button? And can you see other new packages from Synocommunity?

  • CGI Tennet

    I have the DS218+ and the latest DSM (DSM 6.1.3-15152 Update 6) and I have followed all steps above, but “ffmpeg” won’t show up in the list.. I’ve copied the links and changed the trusted settings from stes 3 and 4. Any ideas?

  • Oscar

    Awesome. Thanks for sharing!

  • BakedOn

    This solved all my problems and saved me soooo much time! Thank you so much. BTW I’m on a DS416play DSM 6.1.3-15152 Update 4

  • Oscar

    I just checked and ffmpeg is still there. Current version is 3.3.3-7. Maybe you missed Step 4.

  • TechnoFreek

    Hi, FFMPEG isnt appearing under Community section. Other packages are listed though. I have 216j. Any ideas? Thanks

  • Oscar

    Hi,

    Is this problem only occured on Chromecast? Have you tried playing with other media players?

  • Rasmus

    Hey, I just followed this guide on my DS410 and it didnt help. Still no sound when i cast through my chromecast. Do you know what i can do to fix it?

  • Oscar

    Wow DS416Play can transcode 4k movie. That’s great. Thanks for sharing!

  • Fabien

    Working well on DS416Play , god bless that repository: i can now transcode 4k movie with DTS sound .

  • Oscar

    Hi Nicolas,

    Sorry can’t help you here as I do not have a DS212+. It could be DS212+ not powerful enough or your iPad is not powerful enough? Have you tried with other devices?

    Good luck and let me know how you go.

  • Nicolas

    Well, I tried this on my DS212+, it now allows me to start the movie without any error about the audio channel, but it is first loading the movie for about 4-5 minutes (on my iPad with DS video) and then it plays it for only few minutes before loading again …
    Is my DS212+ not powerful enough ?

  • Oscar

    Good to know it helped! Thanks for sharing 🙂

  • Werner Daehn

    Brilliant. Had been struggling with DTS support all day. For some reason ffmpeg kept saying “DTS … unspecified number of channels”. Did not find anything in google hinting into the proper direction. Input filters, ac command line option,…

    After installing, it still did not work, but for obvious reasons: The command ffmpeg used the old version still as the version number in the console showed.

    Calling
    /volume1/@appstore/ffmpeg/bin/ffmpeg
    did the trick (“volume1” is shown as the install location in my case).

    Thanks very much for your help!

  • Oscar

    Thanks for sharing!

  • Gangxxter

    Doesn’t work with the DS110j